Music On Console (moc) mit PulseAudio spielt viel zu schnell ab…

Habe vor ein paar Wochen mein Audiosetup auf PulseAudio (und ein wenig Jack) umgestellt und seitdem mehr oder weniger auf den Audioplayer „Music on Console“ (moc) verzichtet, weil der keinen Support für PulseAudio hat.

Und selbst wenn man ALSA so einstellt, dass es alles auf PulseAudio wirft, funktioniert dies nur bei der internen Soundkarte richtig, bei Verwendung der externen Soundkarte wird alles viel zu schnell abgespielt. Habe hier und da auch mal an den Samplingraten von moc und PulseAudio etwas verändert, aber es hat nicht funktioniert.

Habe gerade eher zufällig etwas herumprobiert und bemerkt, dass es (zumindest bei mir) funktioniert, wenn man moc mit padsp und dem Treiber für OSS startet:

padsp mocp -R oss

Endlich wieder ein ordentlicher Musikplayer für das Terminal nutzbar :)

Ähnliche Themen...

4 Gedanken zu „Music On Console (moc) mit PulseAudio spielt viel zu schnell ab…“

  1. Als ich damals noch moc verwendet hab, hatte ich keine Probleme, aber vermutlich hatte ich einfach nur Glück, wie du mit der internen Soundkarte. Das einzige was mir per Zufall mal aufgefallen ist, da man im Pulseaudio mehr als 100% laut machen kann, dass der moc damit nicht klarkommt und crasht, weil er den Lautstärke-Balken nicht grösser rendern kann ;)

    Ich benutze allerdings jetzt schon seit Jahren mpd mit ncmpcpp als „frontend“ und bin damit sehr zufreiden und hab auch keinerlei Probleme mit Pulseaudio :)

  2. Hallo natenom,

    das hat bei mir leider auch nicht geholfen.

    funktioniert hats dann mit
    >“PULSE_LATENCY_MSEC=30 mocp“

    dabei benutzt der mocp noch das ALSA plugin.

  3. @bsod: Danke, das scheint sinnvoller als das mit oss, vor allem, weil sich bei mir mocp bei oss irgendwann den ganzen RAM gönnt.

    Mittlerweile auf meinem aktuellen Setup funktioniert es aber auch ohne irgendwelche Tricks :)

Kommentare sind geschlossen.